jQuery 2.0發佈 不再支持IE 6/7/8

jQuery 2.0如期發佈,該版本不再支持IE 6/7/8瀏覽器,因此變的更輕更快,但仍然可以繼續運行在JavaScript環境中,在兼容這些老版本瀏覽器時,由於自身原因,常會產生一些錯誤。但別擔心,jQuery團隊將繼續對1.x 版本分支進行維護,如果你無法拋棄IE 6/7/8,那麼你可以繼續使用jQuery 1.9和即將發佈的1.10。

隨著jQuery 2.0的發布,jQuery團隊對1.x版本的一些環境將不再提供支持,因為2.x版本會是更好的選擇。但對支持老版本IE的非網站場景是提供支持的,它們包括:

  • Google Chrome附加組件
  • Mozilla XUL應用程序和Firefox擴展
  • Firefox OS應用程序
  • Chrome OS應用程序
  • Windows 8 Store (「Modern/Metro UI」) 應用程序
  • BlackBerry 10 WebWorks應用程序
  • PhoneGap/Cordova應用程序
  • Apple UIWebView類
  • Microsoft WebBrowser控件
  • node.js 

由於這些應用處於開發階段,它們自身擁有一套規則或限制,並且與jQuery用在互聯網上的瀏覽器是不同的。雖然我們不能定期在這些非瀏覽器場景下測試,但我們仍然希望聽到,你們在這種情況下使用jQuery的感受。

jQuery 2.0有哪些的變化:

  • 不再支持IE 6/7/8:如果在IE9/10版本中使用「兼容性視圖」模式也將會受到影響。
  • 更輕更快:2.0版本文件與1.9.1相比小了12%。
  • 可以構建一個更小、更輕量的版本。
  • jQuery 2.0 API完全兼容jQuery 1.9 API。 

此外,為了兌現承諾,減少API 1.x與2.x之間的分歧,我們將在未來一兩個月內發佈jQuery 1.10版本。

下載地址:

更多詳細介紹,請查看官網說明

Leave a Comment


NOTE - You can use these HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>